Version 1.6.1.1

Report bugs and glitches you found
Locked
User avatar
DestroyerOfDestruction
Posts: 841
Joined: Thu Oct 18, 2018 2:42 am
Location: Colombia
Discord: BigMaster#4335
Contact:

Version 1.6.1.1

Post by DestroyerOfDestruction » Thu Feb 27, 2020 1:32 am

Disclaimer: I am not a Mega Man Maker team member at the moment, but I am copying the message that WreckingPrograms has left in prior bug reports threads to be practical.

Report bugs/glitches found in version 1.6.1.1 of the game in this thread. Any and all bug reports are appreciated! Do not report bugs found in other versions here.

Please provide as much information about the bug as possible, such as:
  • A detailed description of the bug itself. What oddities did the bug cause?
  • What did you do to trigger the bug?. We need to be able to reproduce the bug to fix it. Screenshots, videos or GIFs would also help here but are not mandatory.
  • If you get an error message, post it. Usually these error messages show where exactly the problem lies, so they are very useful.
  • If your bug is related to the online mode and involved some kind of server error, post the error log. You can find the error log file in %localappdata% > MegaMaker > ErrorLogs. The structure of this file is year_month_day_hour_minute_second.txt. Please send the contents of this file if available.
  • A theory of the cause of the bug, if you have one. If you already have an idea of what caused your bug, it would save us a lot of time.
On top of this, feel free to include any relevant additional information about the bug. Thanks in advance, and happy game breaking!


Lists of bugs not to report
>Gray screen = Server is experiencing heavy load and can't load things up in time
>Error 500 = Server is experiencing heavy load and cannot handle your request at the moment
>Persistence error = Server is experiencing heavy load and cannot handle your request at the moment
>Error 400 = Your profile.ini and user account data don't match, delete profile.ini and try to create the account or log in
>Music still plays after closing the game = Open the task manager and end the game process
>Teleporter disappears at the other side and now it works like a one-way teleporter = It's a pretty cool bug so we've decided to keep it.
>Error -70 while uploading = DM Goldstorm details on how you are connecting to the internet and other data about your PC
> HTTPControl error = restart your MMM client and re-attempt the download. This is likely due to a connection issue.
> "Cannot load buffer file at gml_Script_GME_LoadSong" error = Often, simply restarting your computer and trying again solves the issue. Other times, waiting about a day and trying again works. There is unfortunately no reliable fix.
> "Data structure with index does not exist" error = do the following. Go to %localappdata%/MegaMaker/Settings and delete the files BeatenLevels.sav, PlayedLevels.sav and VotedLevels.sav. Restart the game and it shouldn't crash anymore. Keep in mind that this means the game forgets what levels you have played, beaten or voted on.
Crossing a dangerous river

Colorum
Posts: 7
Joined: Mon Feb 24, 2020 7:20 pm

Re: Version 1.6.1.1

Post by Colorum » Thu Feb 27, 2020 12:23 pm

Same as here: viewtopic.php?f=5&t=9843&start=20#p91020
I stumbled upon a bug with the updated conveyors. I tried loading a stage made in 1.5.5.1 which was a recreation of Metal Man Stage and I got this:
___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Other Event: User Defined 6
for object objBuilderPlacedObject:

Array index must be positive
at gml_Script_calculateConveyorImageIndex
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_calculateConveyorImageIndex (line -1)
gml_Object_objBuilderPlacedObject_Other_16
called from - gml_Object_objInitBuilder_Create_0 (line -1) - <unknown source line>
I guess there's no code for updating old conveyors with their texture index in the editor. Also Forgot to mention that the game crashed and if relevant the stage was already complete with belts and Metal Man, just not uploaded.

ChillWay
Posts: 10
Joined: Thu Feb 27, 2020 4:32 pm

Re: Version 1.6.1.1

Post by ChillWay » Thu Feb 27, 2020 4:41 pm

Here's a crash report:

___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Alarm Event for alarm 9
for object objGlobalControl:

Illegal Buffer Index -1
at gml_Script_GME_LoadSong
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_GME_LoadSong (line -1)
gml_Script_forcePlayNSF
gml_Object_objGlobalControl_Alarm_9

This happens when i try to play any level

ChillWay
Posts: 10
Joined: Thu Feb 27, 2020 4:32 pm

Re: Version 1.6.1.1

Post by ChillWay » Thu Feb 27, 2020 4:44 pm

Here's another crash report:
___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Alarm Event for alarm 9
for object objGlobalControl:

Illegal Buffer Index -1
at gml_Script_GME_LoadSong
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_GME_LoadSong (line -1)
gml_Script_forcePlayNSF
gml_Object_objGlobalControl_Alarm_9

When i try to put music on levels. This don't happen with guts and cut's man themes.

Colorum
Posts: 7
Joined: Mon Feb 24, 2020 7:20 pm

Re: Version 1.6.1.1

Post by Colorum » Thu Feb 27, 2020 7:57 pm

Not trying to be mean, but did you try that:
> "Cannot load buffer file at gml_Script_GME_LoadSong" error = Often, simply restarting your computer and trying again solves the issue. Other times, waiting about a day and trying again works. There is unfortunately no reliable fix.
as stated by DestroyerOfDestruction?

User avatar
DestroyerOfDestruction
Posts: 841
Joined: Thu Oct 18, 2018 2:42 am
Location: Colombia
Discord: BigMaster#4335
Contact:

Re: Version 1.6.1.1

Post by DestroyerOfDestruction » Thu Feb 27, 2020 8:54 pm

Colorum wrote:
Thu Feb 27, 2020 7:57 pm
Not trying to be mean, but did you try that:
> "Cannot load buffer file at gml_Script_GME_LoadSong" error = Often, simply restarting your computer and trying again solves the issue. Other times, waiting about a day and trying again works. There is unfortunately no reliable fix.
as stated by DestroyerOfDestruction?
Technically it was Wrecking. I am just copying the Bug reports message from others for practicity.
Crossing a dangerous river

User avatar
Mega Pokebattlerz
Posts: 440
Joined: Mon Oct 23, 2017 2:11 pm
Location: Nowhere important.
Discord: Mega Pokebattlerz#4489

Re: Version 1.6.1.1

Post by Mega Pokebattlerz » Thu Feb 27, 2020 9:20 pm

Image
Icicle Tecks have some... interesting interactions with Yoku blocks.
ded

ChillWay
Posts: 10
Joined: Thu Feb 27, 2020 4:32 pm

Re: Version 1.6.1.1

Post by ChillWay » Fri Feb 28, 2020 6:18 pm

Yet another crash report:

___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Step Event0
for object objNetcodeControl:

local variable backupBossAddRemove(100006, -2147483648) not set before reading it.
at gml_Script_bldDelObject
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_bldDelObject (line -1)
gml_Script_handleClientData
gml_Script_parseIntermediaryString
gml_Object_objNetcodeControl_Step_0

I tried to remove Bubble man close to a vertical boss door in windows 10

ChillWay
Posts: 10
Joined: Thu Feb 27, 2020 4:32 pm

Re: Version 1.6.1.1

Post by ChillWay » Fri Feb 28, 2020 6:50 pm

More one crash report...


___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Alarm Event for alarm 0
for object objNetcodeControl:

Push :: Execution Error - Variable Index [0,0] out of range [6561,0] - -5.placedCategorySelection(100358,0)
at gml_Script_sendCompleteLevelInfoToClient
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_sendCompleteLevelInfoToClient (line -1)
gml_Object_objNetcodeControl_Alarm_0

This is when someone joins my server

User avatar
Omega Man
Posts: 27
Joined: Wed Dec 05, 2018 12:56 pm

Re: Version 1.6.1.1

Post by Omega Man » Sat Feb 29, 2020 9:27 am

When you add to much acid on the screen the game lags when you add or delete a block
I'm evil.....kinda.

User avatar
02gn
Posts: 553
Joined: Sat Mar 30, 2019 1:49 pm
Location: Poland
Discord: *02gn*#5656
Contact:

Re: Version 1.6.1.1

Post by 02gn » Sat Feb 29, 2020 4:04 pm

Anti Eddie still lacks switching items backwards

I mean this is maybe little bug, but still worth attention.
Last edited by 02gn on Sun Mar 01, 2020 7:38 am, edited 1 time in total.
Image

(Avatar drew by Xartin)

User avatar
ZepperFang
Posts: 240
Joined: Mon Jul 17, 2017 10:41 pm
Location: Brazil
Contact:

Re: Version 1.6.1.1

Post by ZepperFang » Sun Mar 01, 2020 2:33 am

Bounce Man can get stuck in the ground when rebounding & being hit by charged buster.

User avatar
Diamond Wolf
Posts: 740
Joined: Sun Jul 30, 2017 6:48 am
Location: Kimse Neua, Deimos
Discord: Diamond_Miner33#9310

Re: Version 1.6.1.1

Post by Diamond Wolf » Sun Mar 01, 2020 6:54 am

You cannot move screens on the map while in multiplayer. (Tested while joined; not tested while hosting)

You also cannot climb a ladder while in quicksand.
Image

Image

Selling stuff!
SMHCP chips
SHCMP chips
Hologhost ER


#StopSuicideNow

User avatar
DestroyerOfDestruction
Posts: 841
Joined: Thu Oct 18, 2018 2:42 am
Location: Colombia
Discord: BigMaster#4335
Contact:

Re: Version 1.6.1.1

Post by DestroyerOfDestruction » Sun Mar 01, 2020 8:46 pm

Diamond Wolf wrote:
Sun Mar 01, 2020 6:54 am
You cannot move screens on the map while in multiplayer. (Tested while joined; not tested while hosting)
Meka confirmed that that was deliberate.
Moving map on multi is deactivate, and that's intended, it would be mess to sync
Crossing a dangerous river

User avatar
Proto Man V
Posts: 82
Joined: Wed Dec 04, 2019 3:25 pm
Location: Wily's Castle
Discord: DWN-016 Wood Man#6668

Re: Version 1.6.1.1

Post by Proto Man V » Mon Mar 02, 2020 9:45 am

Image

I got softlocked in developer challenges. I could only switch weapons, I couldn't even pause.
Finally...

DETERMINATION.

I may or may not have overexaggerated my hype a bit in a recent forum post

also working on a mod that has yet to be announced

divVerent
Posts: 1
Joined: Wed Mar 04, 2020 4:42 am

Re: Version 1.6.1.1

Post by divVerent » Wed Mar 04, 2020 5:06 am

Getting error 301 when trying to connect now from 1.6.1.1:

tcpdump shows:

Code: Select all

23:37:54.288421 IP 172.17.0.42.50578 > 62.210.69.68.80: Flags [P.], seq 4187381974:4187382205, ack 808160400, win 501, options [nop,nop,TS val 3733544613 ecr 1850928486], length 231: HTTP: POST /MegaMaker/authorize HTTP/1.1
Host: megamanmaker.com
(POST body: my username and password, clearly not pasting here)
23:37:54.390856 IP 62.210.69.68.80 > 172.17.0.42.50578: Flags [P.], seq 1:405, ack 231, win 243, options [nop,nop,TS val 1850934876 ecr 3733544613], length 404: HTTP: HTTP/1.1 301 Moved Permanently
Location: https://megamanmaker.com/MegaMaker/authorize
So it's trying to redirect to HTTPS, but that redirect is not supported by the game. If I go to that URL myself, it seems to be running a Tomcat server.

I don't even know why it's trying plain HTTP. Should it ever try that? If not, something might be wrong on my system (I _am_ running on Linux in WINE), but the issue only appeared like an hour ago while on the same build.

EDIT: must be a problem with my system. Installing WineHQ's wine packages fixed it, so something's wrong on Debian end. Working great now!
Last edited by divVerent on Thu Mar 05, 2020 3:41 am, edited 1 time in total.

masonbooh
Posts: 4
Joined: Mon Apr 22, 2019 3:36 pm

Re: Version 1.6.1.1

Post by masonbooh » Wed Mar 04, 2020 10:50 pm

___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Step EventobjThunderWoolThunderHor
for object prtEnemy:

Unable to find any instance for object index '115381' name '<undefined>'
at gml_Object_prtEnemy_Collision_cfdf9583_ef4a_42e5_9543_db9fabc2fdff
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Object_prtEnemy_Collision_cfdf9583_ef4a_42e5_9543_db9fabc2fdff (line -1)




i just hit pump man with thunder wool and the game killed itself

Locked

Who is online

Users browsing this forum: No registered users and 2 guests