Version 1.6.2

Report bugs and glitches you found
User avatar
WreckingPrograms
Site Admin
Posts: 250
Joined: Sun Jun 04, 2017 6:30 pm
Location: Netherlands
Discord: WreckingPrograms#2152
Contact:

Version 1.6.2

Post by WreckingPrograms » Sat Mar 07, 2020 10:49 pm

Report bugs/glitches found in version 1.6.2 of the game in this thread. Any and all bug reports are appreciated! Do not report bugs found in other versions here.

Please provide as much information about the bug as possible, such as:
  • A detailed description of the bug itself. What oddities did the bug cause?
  • What did you do to trigger the bug?. We need to be able to reproduce the bug to fix it. Screenshots, videos or GIFs would also help here but are not mandatory.
  • If you get an error message, post it. Usually these error messages show where exactly the problem lies, so they are very useful.
  • If your bug is related to the online mode and involved some kind of server error, post the error log. You can find the error log file in %localappdata% > MegaMaker > ErrorLogs. The structure of this file is year_month_day_hour_minute_second.txt. Please send the contents of this file if available.
  • A theory of the cause of the bug, if you have one. If you already have an idea of what caused your bug, it would save us a lot of time.
On top of this, feel free to include any relevant additional information about the bug. Thanks in advance, and happy game breaking!


Lists of bugs not to report
>Gray screen = Server is experiencing heavy load and can't load things up in time
>Error 500 = Server is experiencing heavy load and cannot handle your request at the moment
>Persistence error = Server is experiencing heavy load and cannot handle your request at the moment
>Error 400 = Your profile.ini and user account data don't match, delete profile.ini and try to create the account or log in
>Music still plays after closing the game = Open the task manager and end the game process
>Teleporter disappears at the other side and now it works like a one-way teleporter = It's a pretty cool bug so we've decided to keep it.
>Error -70 while uploading = DM Goldstorm details on how you are connecting to the internet and other data about your PC
> HTTPControl error = restart your MMM client and re-attempt the download. This is likely due to a connection issue.
> "Cannot load buffer file at gml_Script_GME_LoadSong" error = Often, simply restarting your computer and trying again solves the issue. Other times, waiting about a day and trying again works. There is unfortunately no reliable fix.
> "Data structure with index does not exist" error = do the following. Go to %localappdata%/MegaMaker/Settings and delete the files BeatenLevels.sav, PlayedLevels.sav and VotedLevels.sav. Restart the game and it shouldn't crash anymore. Keep in mind that this means the game forgets what levels you have played, beaten or voted on.
Created this game, I guess.

User avatar
NanarieRyoka
Posts: 8
Joined: Sat Mar 07, 2020 11:34 pm

Re: Version 1.6.2

Post by NanarieRyoka » Sun Mar 08, 2020 12:22 am

Not entirely sure if this is a bug, or user error but I wasn't sure where else to post this.
  • A detailed description of the bug itself. Unless I'm running the game in 640x480 resolution via the compatibility tab, the game runs with this odd slowdown, it's not dropping frames, everything just moves like it's underwater (kinda like the megaman legends 2 water dungeon, if you've ever played it)bosses, playable characters, enemies, everything. I know its not the pc, because when I run it in 640x480 it runs better than 95% of the legacy collection games, but makes it impossible for me to get to my stream setup to stream Mega Man Maker (one of the reasons I even bought my pc)
  • What did you do to trigger the bug?. Just ran the program without changing any settings in the compatibility tab, not exactly sure how someone a bit more PC savvy would recreate this though cause let's be honest, It's probably something I'm doing wrong.
  • If you get an error message, post it.No error message, just slow moving everything..
  • If your bug is related to the online mode and involved some kind of server error, post the error log. It's every mode so I guess?
  • A theory of the cause of the bug, if you have one. Honestly I haven't owned a pc since Windows XP was relevant, and while I used to be good with PC's things have changed alot, and I've probably just not optimized something, or changed a setting I needed to somewhere. However I do want to note the pc itself is pretty powerful, being able to run Sea of Theives without any lag or issues, so something like Mega Man Maker shouldn't be pushing my pc beyond it's limits, right?
Come watch me play all sorts of things on Twitch!

https://www.twitch.tv/thelostwielder

Signatures? What is this, Gaia Online? :lol:

masonbooh
Posts: 4
Joined: Mon Apr 22, 2019 3:36 pm

Re: Version 1.6.2

Post by masonbooh » Sun Mar 08, 2020 1:46 am

___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Step EventobjThunderWoolThunderHor
for object prtEnemy:

Unable to find any instance for object index '137199' name '<undefined>'
at gml_Object_prtEnemy_Collision_cfdf9583_ef4a_42e5_9543_db9fabc2fdff
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Object_prtEnemy_Collision_cfdf9583_ef4a_42e5_9543_db9fabc2fdff (line -1)



once again pump man + thunder wool = suicidal game

User avatar
KennyMan666
Posts: 24
Joined: Sat Mar 30, 2019 4:34 pm
Location: Göteboj
Discord: KennyMan666#1335
Contact:

Re: Version 1.6.2

Post by KennyMan666 » Sun Mar 08, 2020 11:30 am

Two weapon-related ones. I posted about the second one in the 1.6 bug thread, but now I got video of it too.

First, Charge Kick. If you get hit by an enemy and then start a Charge Kick, when Mega Man stops blinking, the invulnerability Charge Kick is supposed to grant you no longer applies. Demonstration: https://kenny.next-era.net/mmm/chargekick.webm

Second, Wheel Cutter still does not work properly against shielded enemies. Rather than "tink" off of the shield as it did in Mega Man 10, it simply goes through the shield as if it was not there. If the enemy has a hitbox behind the shield it will hit through the shield, otherwise it will just travel through the enemy. Demonstration: https://kenny.next-era.net/mmm/wheelcutter.webm
Image

User avatar
ZepperFang
Posts: 240
Joined: Mon Jul 17, 2017 10:41 pm
Location: Brazil
Contact:

Re: Version 1.6.2

Post by ZepperFang » Mon Mar 09, 2020 12:32 pm

Boss door x boss room (scroll | enabled)
A boss door is 2 blocks in horizontal. If you place a door 1 block before the screen limit, Mega Man crosses the door AND the screen, then the scroll to the boss room. So, you can go back and get the boss stuck in the walls.

Teleporters
I'm no more able to do the trick with the teleporters, of "erasing the end-teleporter only". When I got it & start a gameplay, the editor has crashed.

Minors
- Still pending a fix to the Silver Tomahawk "automatic" default boss weakness.
- If you "forget" the mini-map enabled and try to edit the boss music (music icon), all the clicks are trapped for the mini-map.
- Still waiting for "water over spikes" and "shadows under boss doors/enemies".

User avatar
Hyenyaku
Posts: 222
Joined: Sun Jun 03, 2018 1:08 pm
Location: Sharo
Discord: [T]ornado[H]yenyaku

Re: Version 1.6.2

Post by Hyenyaku » Mon Mar 09, 2020 4:15 pm

Drop Platforms that are placed vertically consecutively have weird colission behaviours.

https://youtu.be/dMHDMdETN6w
THE MAD KAIZO LAND: #284657
ITEM-2 FUN KAIZO LAND: #289079
THE BLOODY BRUTAL KAIZO LAND: #297986
THE STORMY ACROBATIC KAIZO LAND: #308951
ASSASSIN CLIMBING KAIZO LAND: #350285
PRIMROSE SWAP KAIZO LAND: #368272
MAXIMUM IMPACT KAIZO LAND: #383036

User avatar
KennyMan666
Posts: 24
Joined: Sat Mar 30, 2019 4:34 pm
Location: Göteboj
Discord: KennyMan666#1335
Contact:

Re: Version 1.6.2

Post by KennyMan666 » Mon Mar 09, 2020 4:33 pm

Sliding in certain conditions causes the player character to end up with some weird stray pixels in the wrong colour when having switched to a subweapon. So far the most consistent way to trigger it I have found to be to make a 1-tile gap, walk up towards it from the left, hold right, then slide and release right while sliding. There are other ways to get it as well, sliding or dashing without moving first when you spawn sometimes causes it as well. It occurs on every screen size except 3x. Mega Man, Proto Man and Bass are all affected by it. Video: https://kenny.next-era.net/mmm/pixels.webm

And a picture of an affected Mega Man:

Image

Proto Man gets red and gray instead of blue, so it appears to be some "leftovers" from the default colour - but the pixels show up even if you had already switched to the subweapon before sliding. Moving mainly fixes it, but if you just tiptoe forward one pixel at a time, it can remain for a few steps.
Image

User avatar
14Protoman
Posts: 1118
Joined: Mon Oct 15, 2018 2:24 pm
Location: Argentina

Re: Version 1.6.2

Post by 14Protoman » Mon Mar 09, 2020 10:28 pm

An urgency:
using the chemical solution to build delays the level a lot and even crashes it.

User avatar
14Protoman
Posts: 1118
Joined: Mon Oct 15, 2018 2:24 pm
Location: Argentina

Re: Version 1.6.2

Post by 14Protoman » Wed Mar 11, 2020 6:06 pm

WreckingPrograms wrote:
Sat Mar 07, 2020 10:49 pm
Report bugs/glitches found in version 1.6.2 of the game in this thread. Any and all bug reports are appreciated! Do not report bugs found in other versions here.

Please provide as much information about the bug as possible, such as:
  • A detailed description of the bug itself. What oddities did the bug cause?
  • What did you do to trigger the bug?. We need to be able to reproduce the bug to fix it. Screenshots, videos or GIFs would also help here but are not mandatory.
  • If you get an error message, post it. Usually these error messages show where exactly the problem lies, so they are very useful.
  • If your bug is related to the online mode and involved some kind of server error, post the error log. You can find the error log file in %localappdata% > MegaMaker > ErrorLogs. The structure of this file is year_month_day_hour_minute_second.txt. Please send the contents of this file if available.
  • A theory of the cause of the bug, if you have one. If you already have an idea of what caused your bug, it would save us a lot of time.
On top of this, feel free to include any relevant additional information about the bug. Thanks in advance, and happy game breaking!


Lists of bugs not to report
>Gray screen = Server is experiencing heavy load and can't load things up in time
>Error 500 = Server is experiencing heavy load and cannot handle your request at the moment
>Persistence error = Server is experiencing heavy load and cannot handle your request at the moment
>Error 400 = Your profile.ini and user account data don't match, delete profile.ini and try to create the account or log in
>Music still plays after closing the game = Open the task manager and end the game process
>Teleporter disappears at the other side and now it works like a one-way teleporter = It's a pretty cool bug so we've decided to keep it.
>Error -70 while uploading = DM Goldstorm details on how you are connecting to the internet and other data about your PC
> HTTPControl error = restart your MMM client and re-attempt the download. This is likely due to a connection issue.
> "Cannot load buffer file at gml_Script_GME_LoadSong" error = Often, simply restarting your computer and trying again solves the issue. Other times, waiting about a day and trying again works. There is unfortunately no reliable fix.
> "Data structure with index does not exist" error = do the following. Go to %localappdata%/MegaMaker/Settings and delete the files BeatenLevels.sav, PlayedLevels.sav and VotedLevels.sav. Restart the game and it shouldn't crash anymore. Keep in mind that this means the game forgets what levels you have played, beaten or voted on.
Some weapons like scramble thunder and tornado hold are broken when they play the w.shield of pump man, please fix them.

Alsnille
Posts: 1
Joined: Tue Dec 31, 2019 6:46 pm
Location: Sweden

Re: Version 1.6.2

Post by Alsnille » Wed Mar 11, 2020 8:18 pm

___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Step EventobjWheelCutter
for object prtEnemy:

Unable to find any instance for object index '102361' name '<undefined>'
at gml_Script_sprite_get_xcenter_object
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_sprite_get_xcenter_object (line -1)
gml_Script_checkEnemyUnprotected
gml_Object_prtEnemy_Collision_3af63d68_ec53_4507_8930_3d8f9bd6252a
called from - gml_Object_objWheelCutter_Step_0 (line -1) - <unknown source line>


When using the Wheel Cutter on Bari Heads the game crashes for some reason. It doesn't crash every time, but it tends to do it mostly when I stand on a Bari Head and use the weapon on another one. Doesn't seem like it has anything to do with the Bari bodies. It happened both on a level I played online and a test level I made myself to see if it happened again.

Colorum
Posts: 7
Joined: Mon Feb 24, 2020 7:20 pm

Re: Version 1.6.2

Post by Colorum » Wed Mar 11, 2020 8:36 pm

Third time reporting, sorry to bother you with this again:

___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Other Event: User Defined 6
for object objBuilderPlacedObject:

Array index must be positive
at gml_Script_calculateConveyorImageIndex
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_calculateConveyorImageIndex (line -1)
gml_Object_objBuilderPlacedObject_Other_16
called from - gml_Object_objInitBuilder_Create_0 (line -1) - <unknown source line>

error occurs since 1.6 when loading a finished replica of metal man stage in the editor (made in 1.5.5.1) which isn't (and propably won't be) uploaded. My guess is old conveyors set their field which stores the reference to the conveyor image to -1 as it's unknown which causes a ArraIndexOutOfBoundsException (at least in java, I know this is in gml). changing the gml_Script_calculateConveyorImageIndex to return a default value (probably 0 or 1) would probably fix this (a lot of probably there, sorry). Or at least tell me if I have to redo this level if I want to have this locally.

Also I can confirm that deleting only one teleporter seems to be impossible now. Travelling through one doesn't necessarily crash the game though, destination coordinations might have changed as well, could be a error on my end though (maybe I moved some rooms). Was that a fix or a side effect of a rewrite for example?

Double_Ayy
Posts: 1
Joined: Wed Mar 11, 2020 11:42 pm

Re: Version 1.6.2

Post by Double_Ayy » Thu Mar 12, 2020 12:05 am

Never found this mentioned anywhere and it seemed weird/unintentional, but...

Super adapter damage against bosses
The Super Adapter doesn't seem to scale correctly as a boss weakness.

With no weaknesses set the charged fist does 3 damage.
With primary weakness set the charged fist does 4 damage.
With secondary weakness set the charged fist does only 2 damage, less than it would normally.

AnimeMan
Posts: 60
Joined: Tue Mar 10, 2020 9:55 pm
Location: America
Discord: NS*Smilax
Contact:

Re: Version 1.6.2

Post by AnimeMan » Thu Mar 12, 2020 6:06 am

I was wondering (this may not be a bug) why I can't rate most of the levels that are available for download. I've only seen 2 that allow it.
It's me, NS*Smilax. I've been a Mega Man fan since the Nintendo days. My levels: 389788, 392966, 401751, 401807, 403145, 404278, 410641, 410696, 417674, 417775, 419811, 421469, 424663, 425571, 426232, 426233, 427198, 427521, 428712.

User avatar
RadRobot
Posts: 89
Joined: Sun Jul 16, 2017 9:22 am

Re: Version 1.6.2

Post by RadRobot » Fri Mar 13, 2020 8:54 am

Found a pretty wild glitch randomly while publishing a level. Didn't manage to record the og glitch but was able to perfectly recreate it without too much trouble.

The glitch required me to walk on top a Bari III head, and then jumping vertically into the corner of a block. As i said before, I was able to recreate it so maybe others can too? Afterwards, it sent the camera zooming all the way to the beginning before it stopped at a level boundary, with Mega Man appearing at the beginning.

There was no error message, I just thought it was... peculiar behaviour for a level.

What i think caused it? Maybe something to do with the platform height of the Bari II head, as it may not be a full block height. Nothing else comes to mind, sorry.

Heres the video of it happening:

Stay Radical! :lol:

Latest Levels: :)
- Sootwater Swamp -
- Forces of Nature -

ThisIsRageMan
Posts: 1
Joined: Fri Mar 13, 2020 6:45 pm

Re: Version 1.6.2

Post by ThisIsRageMan » Fri Mar 13, 2020 7:01 pm

So, I think this is a bug, because i'm pretty sure the head of the Bari III shouldn't crash the game when the thunder wool hits it in a certain way. I was trying to use thunder wool to exterminate it, and I crashed the game.
Crash Report:
https://docs.google.com/document/d/1yGm ... sp=sharing

User avatar
Hyenyaku
Posts: 222
Joined: Sun Jun 03, 2018 1:08 pm
Location: Sharo
Discord: [T]ornado[H]yenyaku

Re: Version 1.6.2

Post by Hyenyaku » Sat Mar 14, 2020 7:09 pm

Strange thing happens if Mega Man activate Mirror Buster and then slide through a tunnel to proceed to another room, still holding the fire button.
https://youtu.be/0Xc_xM1fiuk
THE MAD KAIZO LAND: #284657
ITEM-2 FUN KAIZO LAND: #289079
THE BLOODY BRUTAL KAIZO LAND: #297986
THE STORMY ACROBATIC KAIZO LAND: #308951
ASSASSIN CLIMBING KAIZO LAND: #350285
PRIMROSE SWAP KAIZO LAND: #368272
MAXIMUM IMPACT KAIZO LAND: #383036

Rexl
Posts: 15
Joined: Thu Mar 28, 2019 1:05 am

Re: Version 1.6.2

Post by Rexl » Fri Mar 20, 2020 8:36 am

Count Bomb error.
Image
Last edited by Rexl on Fri Mar 20, 2020 8:55 am, edited 1 time in total.

Rexl
Posts: 15
Joined: Thu Mar 28, 2019 1:05 am

Re: Version 1.6.2

Post by Rexl » Fri Mar 20, 2020 8:50 am

Tom Daddy will not appear if you do not place it in a Tileset, however it will appear when you return to the opposite side from where it was placed.

Image

Rexl
Posts: 15
Joined: Thu Mar 28, 2019 1:05 am

Re: Version 1.6.2

Post by Rexl » Fri Mar 20, 2020 9:14 am

The water does not appear completely when putting some level objects and boss doors.

Image

Level object list :

General:
-Count Bomb

Mega Man 1 :
-Fire Beam
-Elec Beam

Mega Man 2 :
-Conveyor Belt

Mega Man 3 :
-Magnet
-Moving Cog
-Wanaan

Mega Man 4 :
-Coil Platform
-Ring Platform

Mega Man 6 :
-Fan
-Spring

Mega Man 7 :
-Floor Light
-Punch Block

Mega Man 8 :
-TNT

Mega Man 9 :
-Bokazurah Block
-Magma Beam Generator

Mega Man 10 :
-Ice Block

Rexl
Posts: 15
Joined: Thu Mar 28, 2019 1:05 am

Re: Version 1.6.2

Post by Rexl » Fri Mar 20, 2020 9:22 am

Rush coil, Proto Coil and Treble Boost will not fall to the ground at certain heights.

Image

Locked

Who is online

Users browsing this forum: No registered users and 2 guests